Lines 4,16: What's the point of found? You never use it.
Line 13: You don't check that the getline() call succeeded.
Line 18: It's poor style to pass control to something that performs admin functions here. adminAuthVer() should do one thing and one thing only and that is to check the password. adminAuthVer() should be a bool function and return whether to allow access or not. adminControl() should be called where adminAuthVer() is called if adminAuthVer() returns true.
Line 21: A second if statement is not required. Use an else.
Line 14: if (input.compare(stringfromfileA))
originally this was supposed to compare my input, to the string within the designated file.
It worked once and then out of nowhere decided not to work.
Line(s) 4, 16: bool found = false;found = true;
At line 4 the false bool was already in place until the compare in line 14 would verify input and string were ==, switching the bool to true and allowing access.
When adminAuthVer is true, it would open adminControl.