Compiling FLTK

I've downloaded FLTK from, unzipped the main folder. Now when I run fltk.dsw, MS Visual C++ 2010 opens and says:

The project 'C:\fltk-1.1.10\visualc\CubeView.dsp' must be converted to the current Visual C++ project format. After it has been converted, you will not be able to edit this project in previous versions of Visual Studio.

Convert and open this project

My book says that's supposed to happen, but then when I hit yes I get:

The project file "C:\fltk-1.1.10\visualc\CubeView.dsp" cannot be loaded. Do you want to remove the unloaded project from the solution?

I have searched the internet and nowhere can I find anything about this. I tried unzipping the folder to another hard drive, re-downloading fltk, copying files from folder to folder...

Someone help please :(

edit: tried a previous version of fltk, 1.1.9, which gives me the exact same errors.
Last edited on
On Windows, I run fltk under cygwin, and I have no problems. Are you sure fltk is supposed to work with Visual Studio?
Yes, I just got it to work after many hours of utter frustration. Turns out I only did two things wrong, copied 7 lib files with CTRL-C instead of CTRL-X, and entered the Additional Depencies wrong.

If anyone ever stumbles upon this topic, take a look at this thread:

It helped me out tremendously.
I'm glad you got it working, and thanks for posting the solution for the next programmer having trouble with this!
Topic archived. No new replies allowed.