[Build Error] [main.o] Error 1 in Dev-C++


Most likely, this problem is not even a problem, rather something I myself have messed up.But here it goes:

I installed Dev-C++ with Mingw on Windows 7(dont ask me why), and tried to compile a program that I already compiled with no problems on the computers at my university. The following Error appeared when I tried to compile it at home:
E:\Users\Black&Yellow\Desktop\Makefile.win [Build Error]  [main.o] Error 1

this is the compile log:

Executing  make...
make.exe -f "E:\Users\Black&Yellow\Desktop\Makefile.win" all
g++.exe -c main.cpp -o main.o -I"E:/Dev-Cpp/lib/gcc/mingw32/3.4.2/include"  -I"E:/Dev-Cpp/include/c++/3.4.2/backward"  -I"E:/Dev-Cpp/include/c++/3.4.2/mingw32"  -I"E:/Dev-Cpp/include/c++/3.4.2"  -I"E:/Dev-Cpp/include"   

'E:\Users\BLACK' is not recognized as an internal or external command,
operable program or batch file.

The system cannot find the path specified.

make.exe: *** [main.o] Error 1

Execution terminated

I then tried to compile any program, and it shows the same error and compile log, even for the most basic template that appears when you make a new console application project.

Also, the install directory for Dev-C++ is E:\Dev-Cpp\, and here are the folders in E:\Users\ directory, maybe that helps:


I am logged in as Black&Yellow, btw, and that is where I save my projects(on the Desktop, or whatever)

Thanks in advance.
Topic archived. No new replies allowed.