SFML Linking Error!!!

Alright, I keep getting this stupid linking error that is saying that it cannot find the sfml-graphics-d.lib file?!?!? I checked the are in which the file should be, and its there! This error keeps coming up! I have been trying to do this with Debug, Release, Static, EVERYTHING!!! It just comes up with the same error?! I seriously think something is blocking this. I ran a quick scan on my Microsoft Security Essentials and no threats were detected... I might be overreacting, but why isnt this working? I am using VS 2010 and version 2.0 of SFML.

Thanks
it cannot find the sfml-graphics-d.lib file


You have to set the lib path in MSVS to where that lib file is stored.

See step #9 here:

http://cplusplus.com/forum/beginner/95295/#msg511542
Thank you soooooooooooooooooooo much for this! :)
The file has been found, but this error comes up: 0x00000d. I have put the command line arguments in, but it isnt working. Does anyone know whats going on?

thanks.
The file has been found, but this error comes up: 0x00000d.


Can you post the actual (full) error message?

EDIT: might be an access violation error... does it say "Access violation when reading/writing address 0x0000000d"? If that's the case you're probably dereferencing a null pointer. If you snap the debugger, it should take you to the offending line of code.

I just explained how to do this in another post to someone else:

http://cplusplus.com/forum/beginner/95876/#msg515013



The only other thing I can think of is that you did not build SFML yourself and used some precompiled binaries you got off the internet. And/or are mixing Debug SFML builds with Release exe binaries (or vice versa). Doing that would also cause a problem.
Last edited on
Topic archived. No new replies allowed.