OpenGL for Windows 8

Hey Guys,

I recently got a new laptop and it has been cursed with the affliction that is Windows 8. I've tried to reinstall Windows 7 on it but to no avail. I am currently enrolled in a Computer Graphics class and we have an assignment that is due on Wednesday and I have been struggling to set up OpenGL. I am using Visual C++ 2010 and cannot seem to get it to work. When telling my instructor of my issue he simply responded with:

Note: 32-bit refers to 32-bit Windows Operating System, and 64-bit refers to 64-bit Windows Operating System

Place copy of "glut32.dll" in the system folder.
32-bit: "C:\Windows\System32"
64-bit: "C:\Windows\SysWOW64"
Place copy of "glut32.lib" in library directory
32-bit: "C:\Program Files\Windows Kits\8.0\Lib\um\x86"
64-bit: "C:\Program Files (x86)\Windows Kits\8.0\Lib\um\x86"
Place copy of "glut.h" in include directory
32-bit: "C:\Program Files\Windows Kits\8.0\Include\um\gl"
64-bit: "C:\Program Files (x86)\Windows Kits\8.0\Include\um\gl"

The issue that I am running into is that the folder
C:\Program Files (x86)\Windows Kits\" does not exist on my machine. Does anyone have any ideas on how to help or can tell me how to set up OpenGL with a different SDK? It would be much appreciated.

If that folder does not exist, you are on a 32-bit machine and can ignore 64-bit stuff.
I'm pretty sure that it is a 64-bit machine.

and either way, it is required for both 64 and 32 bit machines. I swear someone needs to make an OpenGL C++ all inclusive SDK
Last edited on
Ah, I thought you meant that Program Files (x86) didn't exist (I skim-read).

It probably won't work, but you could try creating the folders yourself and putting the files in.
Already tried it, didn't work
I am using Visual C++ 2010 and cannot seem to get it to work.

Have u tried re-installing the vc ? owh and don't forget to choose the debug option. my friend had the same problem before where the folder was missing, can't remember what he did but u can start there.
I'll try that. I've kinda resolved to just writing a C# program to do the drawing with and use XNA to handle the graphics. Not really what he wants but it's something
Have you tried just chucking the header and lib files in your project directory?
Maybe reinstall the Windows SDK, or find where it is currently installed. Do you have a Microsoft SDK folder? In any case you can put the header anywhere and configure your project's include directories to find it.

PS: this has nothing to do with Windows 8. Just saying.
Last edited on
Topic archived. No new replies allowed.