something blocking my paths

after trying many ways to get paths to work for a few GUI libraries on a few compilers i have continually found that paths don't work on either of my two computers
i am absolutely certain that the paths are correct and i've tried putting the libs all over the place with the same result
the only information i've gotten from google is that some background program could be blocking my paths from working and considering that nothing else seems to be the problem i assume that is the case
so if that is the case how do i go about fixing it and if you think that couldn't be the problem or that something else could be causing this then please explain

(i'm using windows 8 and i tried putting the files to be linked from sdl and directx in a folder on my desktop, a folder in c:/, and in the program file and the compilers ii tried are the standard that come with codeblocks, devC++, and visual studio)
Last edited on
Can you show the command you are using to compile the libraries?
Topic archived. No new replies allowed.