Need help building the Boost_1_55_0 /lib folder

I had a problem getting boost_1_55_0 set up correctly (according to the, so I deleted the whole thing and re-did it. I'm using Windows 8.1 and Visual Studio 2013. I downloaded the .7z file and unpacked it. Following the guidelines, I made the boost root directory equal to c:\Program Files\boost\boost_1_55_0. I then ran the example program on the boost getting-started page for windows, the one that uses the lambda header, and it worked fine. So far so good. Most of the libraries in boost are header only (as is lambda), so no binaries have to be built. However, there are over a dozen headers (for example <regex> that DO need to have binaries built in order to use them.

This is where I had a problem. Following the procedure on the boost site, you open up a command window, change to the boost root directory (c:\Program Files\boost\boost_1_55_0)and then type in bootstrap. bootstrap starts the boost build engine. After that operation is completed, you type in .\b2 which starts the build process. The process seemed to be going alright, but after it was finished I didn't have a lib directory. Instead the build created a bin.v2 directory, and the .lib files were burried in that directory around 6 folders deep. The page shows a directory structure where the lib folder should be right inside the boost root directory:


But instead of a lib folder I got a bin.v2 folder with half a dozen descending folders before reaching the .lib files.

Any suggestions on what I have to do to get a lib folder built correctly? Thanks.
Last edited on
For me it built the libs in boost/stage/lib
Fortunately, this youtube explains in detail how to build boost binaries in Visual Studio 2010, and the instructions translate perfectly for Visual Studio 2013 as well. The only thing I had to change was the toolset option to: toolset=msvc-12.0. Executing bjam (instead of b2), I also ended up with a boost/stage/lib directory (along with a bin.v2 directory)! And after linking to the stage/lib directory, the <regex> example program worked! I'm a happy camper! Here is the youtube link:
Topic archived. No new replies allowed.