Can't find solution ???

Here's the question :-
Heroes in Indian movies are capable of superhuman feats. For example, they can jump between buildings, jump onto and from running trains, catch bullets with their hands and teeth and so on. A perceptive follower of such movies would have noticed that there are limits to what even the superheroes can do. For example, if the hero could directly jump to his ultimate destination, that would reduce the action sequence to nothing and thus make the movie quite boring. So he typically labours through a series of superhuman steps to reach his ultimate destination.

In this problem, our hero has to save his wife/mother/child/dog/... held captive by the nasty villain on the top floor of a tall building in the centre of Bombay/Bangkok/Kuala Lumpur/.... Our hero is on top of a (different) building. In order to make the action "interesting" the director has decided that the hero can only jump between buildings that are "close" to each other. The director decides which pairs of buildings are close enough and which are not.

Given the list of buildings, the identity of the building where the hero begins his search, the identity of the building where the captive (wife/mother/child/dog...) is held, and the set of pairs of buildings that the hero can jump across, your aim is determine whether it is possible for the hero to reach the captive. And, if he can reach the captive he would like to do so with minimum number of jumps.

Here is an example. There are 5 buildings, numbered 1,2,...,5, the hero stands on building 1 and the captive is on building 4. The director has decided that buildings 1 and 3, 2 and 3, 1 and 2, 3 and 5 and 4 and 5 are close enough for the hero to jump across. The hero can save the captive by jumping from 1 to 3 and then from 3 to 5 and finally from 5 to 4. (Note that if i and j are close then the hero can jump from i to j as well as from j to i.). In this example, the hero could have also reached 4 by jumping from 1 to 2, 2 to 3, 3 to 5 and finally from 5 to 4. The first route uses 3 jumps while the second one uses 4 jumps. You can verify that 3 jumps is the best possible.

If the director decides that the only pairs of buildings that are close enough are 1 and 3, 1 and 2 and 4 and 5, then the hero would not be able to reach building 4 to save the captive.

Input format

The first line of the input contains two integers N and M. N is the number of buildings: we assume that our buildings are numbered 1,2,...,N. M is the number of pairs of buildings that the director lists as being close enough to jump from one to the other. Each of the next M lines, lines 2,...,M+1, contains a pair of integers representing a pair of buildings that are close. Line i+1 contains integers Ai and Bi, 1 ≤ Ai ≤ N and 1 ≤ Bi ≤ N, indicating that buildings Ai and Bi are close enough. The last line, line M+2 contains a pair of integers S and T, where S is the building from which the Hero starts his search and T is the building where the captive is held.

Output format

If the hero cannot reach the captive print 0. If the hero can reach the captive print out a single integer indicating the number of jumps in the shortest route (in terms of the number of jumps) to reach the captive.

Test Data:

You may assume that 1 ≤ N ≤ 3500 and 1 ≤ M ≤ 1000000. Further, in at least 50% of the inputs 1 ≤ N ≤ 1000 and 1 ≤ M ≤ 200000.

Example:

Here are the inputs and outputs corresponding to the two examples discussed above.

Sample Input 1:

5 5
1 3
2 3
1 2
3 5
4 5
1 4

Sample Output 1:

3

Sample Input 2:

5 3
1 3
1 2
4 5
1 4

Sample Output 2:

0

Test data:

CPU Timelimit: 3 seconds
Memory limit: 64M
Grading style: ioi


Here's my solution code so far :-
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
#include<iostream>
using namespace std;
int main() {
	int i,j,n,m,s,t,buildings[100][100],visited[100][100],tmp1,tmp2;
	cin>>n>>m;
	for (i=0;i<m;i++) {
		cin>>tmp1>>tmp2;
		buildings[tmp1][(buildings[tmp1][0]+1)]=tmp2;
		buildings[tmp1][0]++;
		buildings[tmp2][(buildings[tmp2][0]+1)]=tmp1;
		buildings[tmp2][0]++;
	}
	cin>>s>>t;
	for (i=1;i<=buildings[s][0];i++) {
		while (
	}
}


My idea is to visit through each neighbour of starting building and then visit there unvisited neighbours and so on , if we reach target building , note the steps taken , and keep the shortest path in track , but the problem is that i am unable to code further of my solution , it will be highly appreciated , if any one could help me !
This is a standard breadth first search problem (BFS). BFS algorithm traverses the graph, and it always finds the shortest path from the source to the destination (if the costs of edges are unit costs like in this problem). So basically do a BFS starting from the source, and after it terminates, if the building where the villain is at is unvisited, then it is uneachable otherwise you will have the shortest distance.
Topic archived. No new replies allowed.