Devc++ Bug

i'm trying to write a little software using Devc++
win 32 console software
i have a major issue releated to devc++

everytime i make change to the project, nothing happens. for example

int P1move ()
    cout << P1Name;
    cout << "\nPlease enter the id of your move\n";
    cin >> MoveId;
    cout << Table[0];

if i make some change to it like adding a line
cout << Table[1];

for devc++ i never added that line
even if i add a junk character lines
for example
the software compile as if i didn't add anything instead of giving an error.

i tried to start a new project
an copy paste the whole code
the code works perfectly it recognize the new line added
but then if i try to add a line once again, nothing happens, like as if magic.
another issue similar to this
after compiling it was even reading lines that aren't there anymore

for example
cout << "Hello";

i delete the line
never happened for devc++ the line is still there.
even if it doesn't show the line
it just run the code.

Anyway to fix this? i cannot continue the project unless i find a solution

Edit : I partially solved the issue, if before do Compile and Run
i choose Rebuild all, then cmpile and run, it works as intended.
but before i only had to compile and run. any real fix rather then a workaround?
Last edited on
Are you pressing the compile button? If you just press "Run" I don't think it will automatically compile the code that has changed. Also make sure that you are editing the correct files and not copies of the files.
Compile & Run
shortcut F9

if i do just Run it tells me i must compile before run

i already made sure the files were the correct ones

if i do Rebuild all, it apply the change

if i do Compile & Run or just compile then i run it manually
no changes to it
even if before compile i do
Save all
or save file per file
still the same

only Rebuild all and then Compile & run works now. and this is kinda annoying cause it slow me down

Edit: i forgot to say after what happened
i was writing code, then suddenly Devc++ freeze for no reason, i was forced to force close it. then the issue popped up
Last edited on
Topic archived. No new replies allowed.