vs 2010 error message after running program successfully

Hi there. I have just begun trying to learn SFML 2.0 using VS2010. I have successfully completed first example program which just displays a green circle in a window.

I decided to experiment and added more circles, of different sizes. This was again successful. I then found out how to add text to the window and, after doing this, the program built and ran successfully.

However a strange message then comes up in the IDE after running the program then closing the window:

Unhandled exception at 0x69887a11 in example2.exe:0xC0000005:Access violation reading location 0x00000008.

As I said it builds and runs correctly,just as intended. If I run the program without doing it from the vs 2010 IDE (i.e. by double clicking the exe file) the computer does not give any error messages afterwards.

I thought I would run this past the forum members to see what they think.

you are accessing a null pointer. post your code.
This was an [old] bug in SFML 2.0 with the default font. See details here:


Though according to that page it has been fixed for several months. How old is your version?
Thanks to everyone who took the trouble to look at my post. I wasn't sure if the problem was with SFML or VS 2010. As I said it did not affect the building or running of the program, it was just a curious error.

I used the default font in my practice. I will have to try changing to a different font to see if the error disappears. I read the link given by Disch and to answer another question I am using sfml 2.0 Rc which I downloaded from the SFML site only a couple of days ago. So, assuming this version was up to date, it appears that the bug referred to is still there.

Thanks again
Just to update: I tried to use a different font and the program compiles but refuses to run. If I comment out the references to the new font it is back to normal and running OK. I looked up the help documents, googled it and tried every suggestion that came up but no luck. I know this is not a drastic problem but it is annoying. Is there any way to remove the default font completely?
Last edited on
Topic archived. No new replies allowed.