GDB download

Is the download supposed to include an executable already? Because for the life of me I cannot find it in my download (ver7.6). I've looked at similar questions, but the answers involve looking in the bin directory, which I also cannot find.

gdb.exe specifically.
Last edited on
Bump with what little additional information I can provide.

I downloaded the gdb package (ver 7.6) from:

From there I had no idea what to do. There was no information whatsoever if the debugger needed to be built, or if there were some specific steps to follow.

The best information I could find were from:
But I cannot find any bin directory nor any executable. I looked in the other downloads available, but no luck there either.
I tried following the steps, but I use Windows. And I am unable to use the configure file in the gdb package.

I am stuck and have no idea what to do at this point.

I appreciate any help, thanks.
Is the download supposed to include an executable already?
That depends on what you downloaded and from where.

If you downloaded the source, you're expected to compile it yourself, as well as ensure its dependencies are available.
I went to the gdb website, and navigated to the sourceware page I posted in my previous post.

I skimmed over their different downloads, but I think they're all sources. At least, none of them had any binary release.

And I would love to compile it if I knew how. I saw some files named Makefiles, but they have extensions like def, in, and tpl. I get confused easily, so bare with me.
Which platform do you want gdb for?

Last edited on
For Windows 7 or 8.

I'm trying to set it up with the Code::Blocks IDE and the MinGW compilers.

I recently installed a new MinGW compiler (GCC 4.8), but it didn't come with a debugger, which is why I'm trying to get this one.
Version 7.5.1 of GDB can be obtained from the MinGW project at sourceforge; including the binary package gdb-7.5-1-mingw32-bin.tar.lzma

Last edited on
Thanks! But I must still be doing something wrong... When I run the debugger, it looks like it builds the program, but it doesn't actually run it...
Can you see GDB reporting what's it's up to?

Does your app run outside of the debugger? (I sometimes forget to ensure that libgcc_s_dw2-1.dll and libstdc++-6.dll are on my path.)

Oh wait, I forgot to look at the debug messages.

It says:
Starting the debuggee failed: No executable specified, use `target exec'.

I also tried running the debugger via command-prompt, but I get the same message (I attempted both writing out the exe extension and writing just the executable name).

When I make clean builds, the debugger runs and terminates the program instantly with a good status. This should not happen, because the program I used the debugger on has user input and a single pause at the end.
Last edited on
One possible websearch result:
Breakpoints could not work if the path/folder you've placed your project contains spaces or other special characters. To be safe use English letters, digits and '_'.

closed account (S6k9GNh0)
It's going to be included with any toolset that implements GNU style toolchains (like MinGW or Cygwin).
Last edited on
There is no space nor any special character in the path. Not even an underscore. :(

The MinGW I downloaded was from a distro at nuwen (thanks Catfish for the link). I don't really know names of other debuggers besides GDB, so if the author included a different debugger in there, I wouldn't know....
I use gdb on Windows with cygwin. Have you tried that, rather than messing around with source code?
I was kind of hoping I would be able to use it with an IDE...

New Note:
When I set up Code::Blocks to use the compilers from the distro, the GDB debuggers from andywestken's recommendation and from the default Code::Blocks package come up with the error
No executable specified.

But when using the default compilers that come with the Code::Blocks package with either debugger version, the debug works perfectly.

So now I am very confuzzled.
closed account (S6k9GNh0)
You can. But to be quite serious, if you're on Windows, just use the VC++ debugger. It's more hassle-free.

EDIT: Although, I suppose if it isn't happening on the VC++ executable, you can't do that...

Code::Blocks and CodeLite both come included with MinGW (which includes GDB). Both also come equipped with a GUI to GDB. You can use either out of the box, assuming you can figure out how to work the GUI.
Last edited on
Topic archived. No new replies allowed.