VS13 Install Failure?

I can't get VS13 to install.
It's always complaining about the Core Features package.
Applying execute package: vs_professionalcore, action: Install, path: [cut]\vs_professionalcore.msi, arguments: [cut]
Error 0x80070643: Failed to install MSI package.
Error 0x80070643: Failed to execute MSI package.
Error 0x80070643: Failed to configure per-machine MSI package.
MUX:  Installation size in bytes for package: vs_professionalcore MaxAppDrive: 0  MaxSysDrive: 532811776  AppDrive: 0  SysDrive: 78233600
MUX:  Return Code:0x80070643 Msi Messages:0 Result Detail:WixExecFirewallExceptionsInstall Restart:None
MUX:  Set Result: Return Code=-2147023293 (0x80070643), Error Message=, Result Detail=WixExecFirewallExceptionsInstall, Vital=True, Package Action=Install, Package Id=vs_professionalcore
Applied execute package: vs_professionalcore, result: 0x80070643, restart: None
Error 0x80070643: Failed to execute MSI package.

What gets me is this part:
MUX:  Return Code:0x80070643 Msi Messages:0 Result Detail:WixExecFirewallExceptionsInstall

Tried re-enabling Firewall and Update service and restarting the PC, with no results, two times I redownloaded it (One from the ISO, One from the downloader), also tried this after a manual packages cache cleanup.

Anybody got a clue?
W7 x86
Last edited on
[unhelpful]

VS 2013 is a failure in itself, and moreover an embarrassing move, which would make VS 2012 obsolete less than a year after release. This also hints how bad VS 2012 is, if they're getting ready to release a brand new version less than a year later.

And now that they realized how this looks, they're postponing the RTM release of VS 2013 for as loooooong as they can. I wouldn't be surprised if it came out in late December. Until then, enjoy your Beta... err Preview version.

[/unhelpful]
I can't be the only one that still uses 2010.

They just want your money. Is it express or did you buy it?
@Lumpkin:
The preview edition is completely free of use.
By the way I also use 2k10 right now.
But I want to use <thread> and more C++11 headers, missing in VS10.

@Catfish: The C++11 improvements (and C++03, too) over VS12 are worth it (Both in size and performance).

Probably it was VS12 who failed - as I didn't even bother installing it in the first place.

Q: Why would you say that if you didn't even install/try it?
A: Docs.


Anyways I still can't get to install it.
I think I'll be definitely switching to G++.
The only thing that's scaring me is the absence of #pragma comment, and the makefile structure, but that doesn't look so hard.
Especially with an IDE.
closed account (jwkNwA7f)
@Catfish4 I was thinking it would come out w/Windows 8.1 in October like VS2012 did.
@Lumpkin I used up until about 2 months ago when I got VS2012 Professional.
closed account (o1vk4iN6)
I didn't bother installing the 2013 preview after the installer said it needed Internet Explorer to be installed, I just walked away.

@Catfish666

The only downside of 2012 is really the C++ portion and its lack of C++11 features. Otherwise they had a bunch of new stuff, the UI alone is probably the best. I can make everything a darker color scheme, in 2010 you couldn't change the background color of some of the windows so there was just white splotches contrasting with the darker scheme.
Last edited on
VS2013 is much better then 2012.

You might want to try posting this on MSDN. My only other suggestion is try the possible solution here http://support.microsoft.com/kb/976982
closed account (3qX21hU5)
Visual Studios is making it harder and harder for me to continue to use it regularly :(

The only thing that is keeping me from dropping VS is 1) The Visual Assist plugin that I am in love with and 2) VS really does have some amazing debugging features (I especially love the code map).
Already did that KB, naraku.
I really don't feel like registering on a MS forum...
I don't know which one I should post into, and so on...
I think I've got my set-up.
Seems like CodeBlocks now supports VS10 toolkit (Maybe it was the last update? I didn't remember it could do it with VS <10>, I remember using it with VS08 toolkit tho) and I installed MinGW 4.8.2, so I'm easily able to choose VC features or Debugger & C++0x.
Bad debugger for me, but... :C
Topic archived. No new replies allowed.