Code Insults

Pages: 12
Thanks, that's a good explanation!
1
2
3
4
#include <iostream>
#include <stdio.h>
#include <cstddef>
std::size_t main(){putchar(0x07);std::cin.get();main();return 1337;}
Last edited on
You can use '\a' instead of 0x07
But I wanted to make it less readable. :(
'j > c/++'
@giblit

Too bad that will always result in false >:D

Am I the only one that finds it kind of funny this is legal in C++ ? (Well with VS 2012's compiler it's legal)

1
2
3
4
if(1 > 2)
{
   std::cout << "Basic logic has been broken" << std::endl;
}


Well getting technical, if you left out ++, wouldn't 'j' > 'c' return true?
Last edited on
Too bad that will always result in false >:D

That would be like saying std::cout << "100 > 99" << std::endl; returns false.

Well getting technical, if you left out ++, wouldn't 'j' > 'c' return true?
Technically yes but that wasn't really the point. The point was that I was insulting c/++ saying that J was better.

http://en.wikipedia.org/wiki/J_(programming_language)
http://www.jsoftware.com/
@giblit

Yeah, I was just thinking about J being better than C++, not like you can run an operation inside ' ' lol. I was bringing up 'j' > 'c' as in if you wanted to make that a real operation.

Thanks for informing me of yet another programming language, they just seem so scarce these days!
they just seem so scarce these days!


http://en.wikipedia.org/wiki/List_of_programming_languages
http://esolangs.org/wiki/Language_list (Though these you may not find as helpful but for when you are bored.)
Well, just in case you didn't catch on, I was being sarcastic ;)

Gotta laugh though, no idea C-- existed.
Last edited on
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
class Normal_person
{
 public :
    virtual void eat() = 0;
    virtual void sleep() = 0;
    virtual void do_something() = 0;
};

class Programmer : public Normal_person
{
public :
    void eat()
    {
        _eat();
        code();
    }
    void sleep()
    {
        if( midnight ) {
             Sleep( FIVE_HOUR );
        } else {
            code();
        }
    }
    void do_something()
    {
        code();
    }
    void code()
    {
        code();
    }
    void play()
    {
        code();
    }
    bool hasLife( ) const
    {
        return 0;
    }
};

typedef Programmer You;

int main()
{
    You suck;

    while( !suck.hasLife() ) {
        eat();
        sleep();
        code();
    }
}


I don't think this is insulting at all
Last edited on
Topic archived. No new replies allowed.
Pages: 12