copying sfml to the standard search path

closed account (Dy7SLyTq)
so im trying sfml for the first time, and im running natty. i downloaded sfml and unpacked, and then tried to copy the include folder of sfml to /usr/include/c++/4.5.2, but it said access denied, so i went to my terminal to do it the old fashioned way, but now its saying
cp: omitting directory `./include'
when ever i run cp ./include /usr/include/c++. i am rooted myself so thats not the issue
closed account (Dy7SLyTq)
never mind i just used -I
It should be installed in /usr/local/

The include dir (SFML) in /usr/local/include and the libs in /usr/local/lib
Last edited on
man cp wrote:
-R, -r, --recursive
copy directories recursively
sudo nautilus

and you can copy paste easily... to /usr/local/
closed account (Dy7SLyTq)
im in /usr/local but its not letting me copy/paste
closed account (Dy7SLyTq)
^ignore that i fixed it and got it there
closed account (Dy7SLyTq)
i copied to usr/local but its not finding the directories
Is it not finding the headers, libs, our both? If just libs maybe you need to run ldconfig. I always build sfml from source and usually only install binaries from the repos.
closed account (Dy7SLyTq)
i figured it out. im just compiling with -I and when i eventually generate a make file it wont be that big of a deal
Topic archived. No new replies allowed.