Permission Denied in Ubuntu while running a program via Code::Blocks

I've been using Code::Blocks IDE with GCC compiler in Windows 7 without any problem. I recently installed Ubuntu 12.10 and downloaded Code::Blocks with GCC compiler from the software center. After writing a console application, the program(if there are no errors) builds without any problem. But after i run it, the console window says-Permission denied(Actually the executable file in the bin folder shows-Permission denied). I tried changing the directory in which the projects are saved(Similar problem arose in windows and changing the directory helped), but in vain. Please help! I'm virtually clueless in ubuntu as this is my first linux venture. So please elaborate the solution at the base level! :-(
do you have xterm installed?
Try using either
$ sudo {the name of your program)
when running the program or use
$ chmod 666 {name of your program}
to change the permissions for good.
Last edited on
Topic archived. No new replies allowed.