UNIX/Linux Programming - February 2014

UDP DNS lookup
 
Hello, I'm having a little bit of trouble with my client program. It is suppose to take an address ...
[4 replies] Last: The function takes in the domain name without any "." or "\0" in it. ... (by crimsonzero2)
GCC-specific casting warnings
 
I have a class containing this: class MyClass { void* m_value; int m_type; public: template...
[1 reply] : Isn't the problem caused by returning a value rather than a ref? It y... (by kbw)
by kony
help with OMP
 
Hi there, I need help with the following problem: Multiplication of a matrix by a vector: Ap = q. Th...
[no replies]
MultiThreading I/0 under linux.
 
Hello, Can I write many files from many threads simultaneously?( one file - one thread ) using std...
[3 replies] Last: It is safe to read and write to one instance of a type even if anot... (by kbw)
Editor?
 
hi, i want a grey background editor ! and also if it has sublime's look/features it would be great !...
[7 replies] Last: :o awesome ! thanks so much! btw its banned here trying to download i... (by kam hagh)
Reference to a class is ambiguous XCode
 
So I'm building a program with a class. As i reference anything in it i get the error that the refer...
[1 reply] : Ypu need to post the exact error. (by kbw)
How to get start from windows c++ to Linux c++
 
Hello, Hope you all are doing fine. This is my first query on this form. I have been working on ...
[2 replies] Last: Thanks alot ... GL... I am having the 4th edition of this book. What ... (by vishalkukreja)
by vlaryk
Very large binary files compiled by gcc
 
Hello to everibody! I have a big problem compiling from source apps for Linux. Let us take for exa...
[4 replies] Last: Often stripping is done on all executables in /bin /sbin /usr/bin and ... (by ShodanHo)
Explain the output please
 
Hello. Could some nice soul please explain for me the output of the instruction: system("top -n1 | g...
[4 replies] Last: @naraku9333 Thanks for the correction. I was lazy enough not to try ou... (by abhishekm71)
C++ on Linux
 
I have been learning the Old C++ standard in my school. I knew of the new C++11 standard ...
[7 replies] Last: Firstof all, get yourself a modern compiler. GCC 4.8's g++ is a good c... (by cseder)
Segmentation Fault
 
I'm working on an ascii game, and I'm not far into it (at all) and the following code compiles with ...
[2 replies] Last: Ahh, that makes more sense. Thanks for the reply. (by borix134)
dynamic 2D array creation error
 
Hello. What's wrong with this code snippet? int **lBucket; lBucket = new int...
[2 replies] Last: The code snippet appears correct to me. But why not go the simpler way... (by Catfish666)
g++ compiler for terminal mac
 
Before, I was able to compile on my terminal via g++. I tried installing a new compiler such as mp-g...
[4 replies] Last: Install the Xcode command line tools too. If you have latest Xcode the... (by codewalker)
Write a C++ program that asks for the URL of a PDF file, downloads it, and displays it with xpdf
 
Write a program named hw3pr3.cpp which asks the user for the URL of a PDF file, checks that the URL...
[1 reply] : That is your homework. Where is your question? (by keskiverto)
by Syntax
C or C++ on mac
 
i just install Xcode and i want to make app for apple but i not sure what i should start with c++ or...
[3 replies] Last: Thanks i start with C book then.Thanks for the help:) (by Syntax)
by Chubby
Bus error (core dumped)
 
why my mode is pointer???? when it an array xcode run it! #include <iostream> #include <ctime> ...
[6 replies] Last: Can anyone show me how to fix so it not a pointer? No, you can not ... (by Grey Wolf)
LED on a simple breadboard and interfacing it with intel atom processor with linux
 
I have got a LED on a simple breadboard and I want to interface it with intel atom processor which i...
[1 reply] : How does the breadboard connect to the intel atom processor? This deta... (by ShodanHo)
Code:Blocks with SDL
 
Does anyone here know how to setup or where to find a good tutorial on how to use SDL with Code:Bloc...
[2 replies] Last: Hello, I'd just like to tell you that SDL 1.2 is now old. You should ... (by Avilius)
Doubly Linked List class- Insert
 
Hi, I'm having some seg faults when I try to implement an Insert function with a doubly linked list ...
[1 reply] : http://www.cplusplus.com/forum/general/112111/ ┬┐what's the differen... (by ne555)
by bob610
ftruncate was not declared in this scope
 
I am make a program for a raspberry pi running Arch Linux. I need to set the size of a shared memory...
[2 replies] Last: I just tried that and it is there, then I realized that the error was ... (by bob610)
February 2014 Pages: 12
  Archived months: [jan2014] [mar2014]

This is an archived page. To post a new message, go to the current page.