UNIX/Linux Programming - July 2012

udp client/server
 
this is my udp client code.... #include<iostream> #include<arpa/inet.h> #include<unistd.h> ...
[1 reply] : The real problem is that the server isn't binding to an address. As a... (by kbw)
by Toffie
Debug help needed.
 
I'm currently busy with a C++ course, in a chapter about handling batches of data. The Chapter star...
[2 replies] Last: haha i was about to remove topic after i found the problem with Qt's d... (by Toffie)
by sanyam
Best Linux Flavor for C++ Prgramming
 
I have been using Windows ever since. I have never worked on a LINUX Platform. I want to learn C++ p...
[17 replies] Last: You can always make your own distro: http://susestudio.com/ There's a... (by Catfish2)
starting graphics programming
 
Hello all I want to move from terminal programs to graphical programs but i dont know where to st...
[4 replies] Last: Can you tell me if this is the recommended way to install openGL?All i... (by giannhssdra)
Problem in separating values in text file
 
Hi guys, i am trying to separate the first 2 values in a array which are the currency name and price...
[4 replies] Last: Thanks guys for all your help. I solved it using string tokens =) (by CLearner88)
by alend
Compiling c++ with Armadillo library at NeatBeans
 
I am going to compile C++ program which contains Armadillo library. This issue is feasible via comm...
[3 replies] Last: This is most likely caused by a previous version of Armadillo interfer... (by mtall)
Implement a Program that consumes a .so file using runtime linking that calls an embedded header file
 
I need to implement a program that uses runtime linking and calls a created header file. The header ...
[1 reply] : I'm not to sure about some of the rest of the code, but right off the ... (by Ryhnn)
QT
 
hi I'm a c++ programmer I'm using Qt creator ... it's the best but when I press run, the termina...
[3 replies] Last: any code ... even if the first Hello world ! code (by Sarah93)
measuring time
 
Hello all I would like to know what are my options for measuring time in my program. Im already ...
[2 replies] Last: Another option: http://cplusplus.com/reference/std/chrono/system_clock... (by majidkamali1370)
monodevelop
 
hi I'm using monodevelop IDE in ubuntu 14.01 but this compiler doesn't help me!! ex. when I writ...
[11 replies] Last: I agree with Moschops. If you learn g++ command line options, you can ... (by majidkamali1370)
by sever
Working with utf8 strings
 
Hi, I'd like to ask you for the best way to get the character size (not the bytes size) of utf8 c...
[no replies]
by ndpndp
Pthreads to compute Pi (1,2)
 
I am planning to use parallelization for the code shown below to compute the value of a pi. Can anyo...
[23 replies] Last: Hmm, interesting enough that I checked how it would be in Scala: Firs... (by rapidcoder)
namespaces confusion
 
Hello In one header file i have a namespace IMAGE with a class in it. namespace IMAGE { clas...
[4 replies] Last: Actually it doesnt work if i just include header2 in header1. Giving e... (by giannhssdra)
by Ryhnn
COUT not displaying
 
I'm writing a small program to mimic the unix tail -f command. I'm confident I am doing it correctl...
[6 replies] Last: Yeah, already figured that out. had some inverse logic going on. Than... (by Ryhnn)
gtk+ compiling error by include iostream
 
hi i wrote program that uses gtk and gstreamer when i try to compile it and it has header iostream i...
[5 replies] Last: You may be interested in this project which allows you to create GTK+ ... (by Matt Flax)
Automated SSH with C++
 
Hi. This time, I have a rather big goal. This program that I am creating will be passed out to 2 of ...
[9 replies] Last: Password-less logins with OpenSSH http://www.debian-administration.o... (by kbw)
Problem (core dumped) with a list of class "aut_st"
 
Hi, this is my first topic here, I need help, please. I have a class autst.c and I declared a li...
[6 replies] Last: Hey, thanks a bunch for your attention! =) I've fixed the problem. I... (by toncorrea)
ofstream not working the way I want it to Ubuntu 12.04
 
I have a program which creates a configuration directory inside of a directory called "a" and puts a...
[5 replies] Last: Nevermind. I have solved this problem by doing the following: string... (by awesomeprograms)
cilkplus with gcc
 
Hello all Has anyone installed and worked with the gcc-cilkplus branch? I've installed it on ubu...
[no replies]
by ssaa
template function
 
Hello everyone, sorry for the bad English. I have a problem with the template functions. I have the...
[5 replies] Last: fstream isn't derived from ofstream (by Cubbi)
July 2012 Pages: 12
  Archived months: [jun2012] [aug2012]

This is an archived page. To post a new message, go to the current page.