Visual Studio behaving Weirdly?

Hi,

Currently I am using Visual Studio 2012 Ultimate. I a am working on a massive project right now, which would mean I have multiple dozens of files with many tens & thousands of line(s) of code. This needs IDE assistance on a enormous scale, but the IDE is not acting stupid and weird.

VS2012 is underlining almost every variable and other random strings and suggesting it is undefined but when I go to the variable and click go to definition it takes me to the initialization which is correct. Then why is VS2012 acting weird.

I checked whole code for few hours, 3 hours to be exact , and still it is underlining random strings.

Anyone ever have this problem before. Please tell me how to short it out.



Other Details:

Matching lines: 69472  Matching files: 43  Total files searched: 43 




Have you tried rebooting the PC and then rebuilding the entire project?

Sounds like that project could do with being split accross a few DLL's just to reduce the size of the main project down to a more maintanable size.
Yes! I did reboot my PC and rebuild the entire project and yet it still shows the same old errors, even though the compilation happens without error.

No chance, The project especially is a security utility meaning it, should not have externel dependency such as DLL because if someone deletes the DLL the whole application would be unable to run properly. Next I am performing Inline Hooking which is far more effective than DLL injection keeping in mind DLL injection are easy to un-hook.

The other critical thing which mean I cannot use DLL is becuase the actual exe will be buried in the MBR, which means after it is there it is impossible to use external DLL unless I mannually Un-map them.

If any un-map fails the whole system could have do wrong JMP and crash un-bootable so It is not a option.

As for now the MBR module works but the actual IDE is messing up. So I cannot continue my work becuase these type of projects need comfort features right.


EDIT: Also bypassing the ALSR would be impossible because I am doing a Stack Controlled Error to trick ALSR until my Program attaches it self to MBR becuase then My program can scan the whole system with more power.

And useful for bypassing the Windows UEFI
Last edited on
Anyone attempt to solve my problem please.
You said the program compiles and runs correctly, is it running in both debug and release mode?

You might be running into a bug that is specific to your installation. Have you tried it in VS2010 or other compiler? If they also have the problem then there is something wrong with your code, if they don't have the same problem then it is specific to your installed version and you could try re-downloading and reinstalling your compiler, or just use the other compilers.


We can't solve your problem because we don't have any of your code and haven't run into the same problem, but those are the only suggestions I could think of.
Last edited on
it is currently on debug mode.

I re-installed it and still the same problem arises. Also no there is no error with my code, I can put money on that all those error's are baseless. I have tried VS2010 but these "problems" are gone but the thing is that VS2012 is something I prefer working with I need my comfort here because the project I am working on is not a simple project but a sensitive project in sense it needs to be dealt very carefully.

Code which is apparently wrong:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
DWORD szJmpMbr()
{
int szInstallationBootID = 10;

if(!CheckID(szInstallationBootID))
{
MessageBox(0,"Space Trace could not install the - MBR Module. There is already a MBR module installed.","Failure",MB_OK|MB_ICONERROR);
exit(1);
}

 /*   Developer Notice:
  *   There must be only one Boot ID on each machine before the Boot  
  *   Sector Module will be attached to MBR. If there same ID throw a Error
  *   Message Box. - DONE
  */ 

if( InstallMBRModule(szInstallationBootID) == 1)
{
MessageBox(0,"Space Trace, has successfully installed MBR module","Success!",MB_OK|MB_ICONINFORMATION); 
}else{
MessageBox(0,"Failure to install MBR. Due to a application protecting MBR from being Modified ","Failure",MB_OK|MB_ICONERROR):
}

return 0;
}


it says: szInstallationBootID is undefined

Why is that. But when I compile it, the program works without compiler throwing a error.

Thanks!
Last edited on
All I can do from here is confirm that the code looks good, when I pasted it in my compiler (VS2012) there were no errors with szInstallationBootID, and nothing wrong with the function (besides the errors due to the other functions not being available).

Sorry, I don't have any fixes for you.

Have you tried the full program on a different computer but still in VS2012? ... I'm basically fishing for sticks, maybe there is some setting on your main computer that is causing the problem.... did you make any changes to the project properties or debugger settings?

I've had issues where something similar was being caused by a function that I had previously thought was unrelated, but the program shouldn't be compiling if that were the case. I'm assuming you've been checking all functions where the problem occurs.

Maybe go with the "lost my keys" method and check on everything that you'd made changes to before the problem arose.

Good luck, and worse case scenario is that you'll just have to ignore the problem since it doesn't seem to be harming your actual program.
Last edited on
Yes, on a different computer I tried this, it works great. With the exact same settings I tried and it works great but on my computer it does not.

I informed Microsoft Team about this and got a reply that it was due to me having 5 VS2012 open with around 100,000 lines of code and because of that my machine is swapping my RAM around and closing few projects will make RAM more available for usage.

Thanks newbieg for the help and Microsoft thanks for quick answers.

Thread Closed
Topic archived. No new replies allowed.