C++/CLI Form Application Compiling Issues

Okay, so I can compile a C++/CLI form application fine if I set the RunTime Library inside of Code Generation to Multi-Threaded DLL. When I try to compile as Multi-Threaded, I get this error

1>------ Build started: Project: MySQLProjectWithForm, Configuration: Release Win32 ------
1>cl : Command line error D8016: '/clr' and '/MT' command-line options are incompatible
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

My issue is that when I e-mail out the program to a friend (compiled as Multi-Threaded DLL) and they try to run it, they get the error that MSVCR110.dll is missing. They've already installed the Microsoft Visual Redistributable 2012 Package Update 4.

I've tried sending a copy of my MSVCR110.dll to them to place in the same folder as the application, but then they get this error

The application was unable to start correctly (0xv000007b). Click OK to close the application.

If anyone can help me figure out what I need to do for my program to be able to run on other people's computers it would be extremely helpful.

Thanks for taking the time to view.
Last edited on
closed account (j3Rz8vqX)
From Microsoft:
MSVCR110.dll is the Microsoft Visual C++ Redistributable dll that is needed for projects built with Visual Studio 2011. The dll letters spell this out.
MS = Microsoft, V = Visual, C = C++, R = Redistributable
For Winroy to get started, this file is probably needed.
This error appears when you wish to run a software which require the Microsoft Visual C++ Redistributable 2012. The redistributable can easily be downloaded on the Microsoft website as x86 or x64 edition. Depending on the software you wish to install you need to install either the 32 bit or the 64 bit version. Refer the following link:


Looks like your answer, but I am not certain.
Read the thread on your own for possible assistance.

Possibly she needs the distribution package.
Thanks for trying, but please read my whole post next time. They've already installed Microsoft Visual Redistributable 2012 Update 4 for 64 bit. I did it on their PC. I've also installed the .Net Framework 4.5 which is what the project used and still no luck. The only thing I can think of is installing VS2012 on their PC, but this can't be a reasonable solution there has to be another way.

Thanks again for your time though.
They've already installed Microsoft Visual Redistributable 2012 Update 4 for 64 bit

That's the problem. You need 32 bit runtime even if users run 64 bit version of windows. Alternatively,you can put 32 bit versions of msvcp110.dll and msvcr110.dll in the same folder as your application, as you already tried, but again you need 32 bit versions of these DLLs
Thanks for your reply, Modoran.
I forgot to mention this before, but I also tried downloading the MSVCR 2012 Update 4 for 32 bit. When I have the 32 bit installed on the pc that i'm trying, I just get an error that says
"The application has stopped working." and it's the same idea as when a program stops responding.

I tried moving the MSVCR110.dll (32bit) and the MSVCP (32bit) dlls to the folder, and it's still the same result.

Once I uninstall 32 bit MSVCR 2012, it goes back to the error that it can't find MSVCR110.dll.

If anyone would want to test it for themselves, here is a link to a blank form project, but it still functions the same way as the program i'm trying to fix. Since it uses CLR, it will compile in the same manner.

Once again I really appreciate you guys looking into this.
Last edited on
You can avoid this problem when you use static linking of the runtime library.

/MT instead of /MD (Project setting -> C/C++ -> code generation -> runtime library)
Try having the user install the Microsoft redistributable package on their system.
Topic archived. No new replies allowed.