OpenNN adding to a Visual C++ Studio 2017 Project

Good Night.

My name is Hector Perez. I am an international student from Guatemala studying Computer Science and Music. I am very interested in using OpenNN for a Computer-Music project. I have tried today to create a Visual C++ project that has the appropriate dependencies (as stated in <<OpenNN Doc>>).

However, I think after some attempts, I realized I was probably doing something wrong. I include my procedure after the end of this message.
I would highly appreciate it if you can point me to a tutorial where it performs a project build step by step.

My procedure:

. 1.Created a C++ project in Visual Studio.
2. Right clicked the application folder in the Solution Explorer,
3. Went to Properties under VC++ Directories.
4. Copied the full paths for the dependencies into 'Include Directories'.
5. I built the project, but errors occur - as if the files are not found.
6. They are found if I explicitly use #include, but that's probably not the intent.
This is the kind of error I get. (JUST WAY BIGGER ! )

... SimplePatternRecognition.obj : error LNK2019: unresolved external symbol "public: void __cdecl OpenNN::NeuralNetwork::save(class std::basic_string<char,struct std::char_traits<char>,class std::allocator<char> > const &)const " (?save@NeuralNetwork@OpenNN@@QEBAXAEBV?$basic_string@DU?$char_traits@D@std@@V?$allocator@D@2@@std@@@Z) referenced in function main
1>...C:\Users\Owner\documents\visual studio 2017\Projects\SimplePatternRecognition\x64\Debug\SimplePatternRecognition.exe : fatal error LNK1120: 46 unresolved externals
1>Done building project "SimplePatternRecognition.vcxproj" -- FAILED.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========
Have you actually linked the lib? If all you did was those steps you wrote, then you haven't.
There was originally NO .lib file. --- I tried building OpenNN with CMake, and posteriorly built a .sln file it created using Visual studio. And this created the .lib file. I had a development. I realized from research that probably a .lib file needs to be added, as well as the directory where the .lib file is (to Visual Studio Project). Using CMake, I was able to build the .lib file !!!

I tried now adding the .lib file to the project simplepattern recognition. The problem I have now is that it says that the .lib is x86, and the project is x64. This is a console project in Visual Studio 2017 , and only 32 bit option is available :(
Still need help - appreciate it! Thanks !
THANKS @GoldenLizard
x86 is 32-bit. Check the droplist just below the menus and change x64 to x86, or rebuild the lib for x64.
I am not sure if that's the only problem, but I will try .
I am pretty sure I had changed those x64 to x86 at some point.
I think it's something else with the include directories, and lib directory.

Thanks though
I SOLVED IT!
LOOK AT MY GIT REPO README.MD TO SEE HOW !

https://github.com/HectorGit/allMyOpenNNCode
Registered users can post here. Sign in or register to post.