TBB Cmake error in mingw

Dear all,

I am now introducing Intel TBB in the cmake build system of mingw compiler.

I tried the procedure similar to the below URL item "Source code integration of Intel TBB to the sub_string_finder sample (Linux* OS)"<https://github.com/01org/tbb/tree/tbb_2019/cmake#tbbget>

To build TBB library is succeeded in cmake generation,
but in "make" process, I failed linking as the below log.



>>TBB library is successfully made (.o & .d files, they correctly worked in ordinary tutorial case without cmake).
>>Probably, Makefile is configured for MSVS compiler since ***.lib is windows static library format.

If you know how to cope with this case,
I would appreciate it if you could help me.





Best regards

=============================================================================================================

Scanning dependencies of target tbb_test

mingw32-make.exe[3]: *** No rule to make target 'tbb_cmake_build/tbb_cmake_build_subdir_debug/tbb_debug.lib', needed by 'tbb_test.exe'. Stop.

mingw32-make.exe[3]: *** Waiting for unfinished jobs....

[ 50%] Building CXX object CMakeFiles/tbb_test.dir/main.cpp.obj

mingw32-make.exe[2]: *** [CMakeFiles\Makefile2:67: CMakeFiles/tbb_test.dir/all] Error 2

mingw32-make.exe[1]: *** [CMakeFiles\Makefile2:79: CMakeFiles/tbb_test.dir/rule] Error 2

mingw32-make.exe: *** [Makefile:117: tbb_test] Error 2

=============================================================================================================

Dear all,

I resolved this problem by no use of the tbb_build procedure.

(TBB library is in advance built, and link them directly by cmake command, "link_directory" and "target_link_libraries" with linker options, -ltbb)

Sincerely
Registered users can post here. Sign in or register to post.