Compatible IDE, compiler and graphics lib

I've been trying this for a while now with no success. Could anyone give me a link to compatible versions of codeblocks, minGW, and sfml 2.1?
Thank you so much. I think I must have had an older version of code::blocks because it wasn't working, btu now I can carry on with the programming of a game I made with winbgim that needed more functionality than winbgim was capable of producing.
Registered users can post here. Sign in or register to post.