SFML Woes...

I'm with a friend right now trying to install SFML and am having an abundance of problems. It seems we've both managed to get this error:

This application has failed to start because libgcc_s_dw2-1.dll was not found. Re-installing the application may fix this problem.

I'm not really sure what's going on here. I've scavenged for the .dll, used some linker options, but no luck. If anyone has had similar problems or knows what's going on, that would be great.

We are using Code::Blocks and SFML 1.6

Last edited on
Try to do what it says: reinstall the compiler or the IDE ( or both )
I've reinstalled Code::Blocks twice and SFML three times. I guess another fresh reinstall wouldn't hurt though...
That, oddly enough, is the exact link I went too earlier. I tried all the solutions but to no avail. I'll just cross my fingers and do a fresh install again.
Last edited on
have you tried code::blocks with compiler package?
You mean install Code::Blocks with MinGW? If so, yes, that's what I did.
This is the version of code::blocks I'm using and it's working find.

Maybe the problem here is that your SFML binaries are compiled in a different version of Mingw. Try compiling SFML on your own.
That has nothing to do with SFML. That's the GNU runtime library -- which for licensing purposes is now in a DLL. The problem is that the DLL is not in your PATH, so when you run the application, it cannot find the DLL, and so complains.

You'll find it in the 'bin' directory of your MinGW install. You can copy it to your C:\WINDOWS\system32 directory and/or copy it to the same directory as your executable.

Good luck!
Oh! It's nice to have someone to correct and educate me. Anyway compiling on my own works for me without libgcc_s_dw2-1.dll
correct me if im wrong... i think codeblocks installation also copies that dll to system32 folder..

The closest thing I could find to it was libgcc_s_sjlj-1.dll
It has to have the exact same name or the program won't be able to find it. Don't try renaming it.
I fixed it by installing a dw2 version of TDM-GCC by using the on demand installer.
Topic archived. No new replies allowed.