What is the best name for the function I wrote?

I wrote a function that uses standard algorithm std::accumulate. It does the same work but for some specific sequence. So I named it as

bla_bla_accumulate

It uses std::algorithm without predicate.
And now I have decided to write the same function but with predicate. I can not use the same name because the function has a default parameter so the compiler will not be able to select one of them due to ambiguity.

So the question is will it be correct to name it as bla_bla_accumulate_with from the point of view of English? I mean the with after the original name.
with is certainly reasonable.
Thank you.

Now I will think about how to substitute correctly the prefix bla_bla for something meaningful that the identifier would not be very long.
Topic archived. No new replies allowed.