Writing a program and am stuck

Hi. I am working on this program:

CSCI 1470

1. A local scientific lab stores hazardous chemicals for local manufacturing companies until they can be properly disposed of. The lab would like for you to write a C++ program to calculate the storage charges based on the volume of the shape required for the particular material being stored.
a) The user will enter the name of the company requesting the storage, the desired shape for the chemical being stored via a menu option, and the dimensions of the shape.
• Build an appropriate menu for the user that displays the three choices of shapes available with an option to also quit the program. Prompt the user for the desired menu choice. If the menu choice is invalid, display an error message.
• Read the dimensions of the desired shape from the user.
b) Calculate the volume of the desired shape, the handling charge, and the storage charge based on the volume. Also calculate the total charges.
c) Display the name of the company requesting the service, the name of the chosen storage shape, the dimension of the shape, the calculated volume to a tenth of a decimal point, the handling charge, the storage charge, and the total charges based on the following criteria table. (Use symbolic constants where appropriate. Use 3.1416 to represent the value of PI.)
The formulas for the volumes are:
a. Volume of a cylinder = PI r2 h
b. Volume of a sphere = 4/3 PI r3
c. Volume of a cone = 1/3 PI r2 h



Cylinder Sphere Cone


The Storage and Handling charges are based on the following criteria:

Volume (x cubic inches) Handling Charge Storage Charge based on Volume
0 < x <= 150 $2.35 $0.15 per cubic inch
150 < x <= 250 $5.75 $0.25 for each cubic inch > 150
250 < x <= 350 $10.50 $0.35 for each cubic inch > 250
x > 350 $15.25 $0.45 for each cubic inch > 350


Sample Input #1:
Enter the company name: Ward Bus Company
Please enter your choice of shape from the following menu:

1. Cylinder
2. Sphere
3. Cone
4. Quit

Enter Menu Choice:? 3

Enter the radius of the cone: ? 5.3
Enter the height of the cone: ? 9.4

Sample Output:

Storage Bill for Ward Bus Company

Dimensions of the cone:
Radius: 5.3 inches
Height: 9.4 inches

Volume: 276.5 cubic inches

Handling Charge………………..$10.50
Storage Charge………………… $9.28
Total Charges…………………... $19.78

This is what i have so far:

//To calculate the storage charges based on the volume of the shape required for a particular material being stored

#include<iostream>
#include<string>
#include<iomanip>
#include<cmath>

using namespace std;

const double PI = 3.1416;
int ERROR;

int main(void)
{
//Variables to store name of company and shape of containers
string company_name;
string containerShape;
string dimensions;
string HandlingCharge; //handling charge amounts
//string StorageChargeBasedonVolume; //to get storage charges
string QUIT_CHOICE;
string choice;
string Choice_1, Choice_2, Choice_3, Choice_4;
string CHOICE_1, CHOICE_2, CHOICE_3, CHOICE_4;

//Stores radius and height entered by the user
double raidus = 0.0;
double height = 0.0;
double volume_x_cubic_inches; //to get cubic inches
double Volume = 0;
double x = 0;
double handling_charge = 0;
double storage_charge = 0;
double total_charges = 0;
double StorageChargeBasedonVolume;

//char choice;
//char MENU_CHOICE;

//Format output values
cout << setprecision(2) << fixed << showpoint;

//Prompt user for input
cout << "\nEnter the company name: ";
cin >> company_name;
//cout << "\nPlease enter your choice of shape from the following menu: " << endl;

//Display the choice of the shape chosen
{
char choice;
cout << "\nPlease enter your choice of shape from the following menu: " << endl;

//Separate input from output
cout << endl << endl;

cout << "1. Cylinder " << endl;
cout << "2. Sphere " << endl;
cout << "3. Cone " << endl;
cout << "4. Quit " << endl;

//Separate input from output
cout << endl << endl;

cout << "Enter Menu Choice: ";
cin >> choice;

}
}


I can't select a choice when I try to type in a number and I am confused as to doing the switch statement. Can anyone walk me through this? Thanks!!
Topic archived. No new replies allowed.