• Forum
  • Lounge
  • Assembly - How to assemble TASM programs

 
Assembly - How to assemble TASM programs

Ive tried so many different IDEs and they all seem to be for MASM and this is not what I want to use. So, I thought that notepad++ might be good for this. (I tried NppExec, but it just gave me more problems) If anyone knows how to do this, would be very thankful, but t be honest, I dont care what IDE I use, I just want to be able to start coding.

thanks
I use nasm, but I never use an IDE...
From Google:

http://nasmdevelopide.codeplex.com/

(Remember to look at the requirements)
I use a virtual machine now, so I can run 16 bit code from my computer. Ive been having trouble because I sometimes use the commands to run code from the nasm command line, but it never works. things like -f elf work, but things like win32 dont. Im confuse on what I have to do to run a simple program.

hello again, what I have to do to run the code now. So, I typed this command:
-f win32 (path to file)

so I get these errors:
more than one input file specified.


This came up 4 times. Here is my code:
1
2
3
4
5
6
7
org 100h
mov dx,msg
mov ah,9
int 21h
mov ah,4Ch
int 21h
msg db 'Hello, World!',0Dh,0Ah,'$ 


i copied this off the internt just to test, so it might be something wrong with this. I was reading somwhere (cant remember where) that the entry point of the program might affect the file format it is supposed to be assembled in. like org100h is usually put whenever someone wants to assemble a specific file format. Whats wrong with this. (Sorry if I started to sound like I was blabbering on about something vaguely similar to assembly, I was trying to give as much info as I could)
Normally I won't give anyone a hard time about choice of system, but here I will.

(1) It appears you are trying to learn assembly programming. For that, nearly any tool will do.

(2) You have not given a good reason for using TASM over MASM. The first is an older tool that is no longer developed. The second is still maintained and it is a superior system.

(3) Any decent IDE will let you work with plain text files. Google offers a number of solutions that target assembly.
http://www.google.com/search?q=assembler+ide

(4) It looks like you need some help understanding how to use your tools. For example, -f win32 (path to file) is not a valid command on Windows (or any other system I am familiar with).

Nor are they valid command-line options to TASM (AFAIK). If you were to type them as argument to TASM, I would expect you to get the error message you show us.


If you google around "turbo assembler" and "tasm" with "tutorial" and "getting started" you will get a lot of great hits helping you actually compile your program.

Also, you should be aware that modern Windows systems no longer support the DOS interrupts. You will need to be running an emulator to execute old 16-bit programs.


If you really are just trying to learn assembly, you are much better off using MASM32 right from the start. The guys at Microsoft have spent a whole lot of time making it very, very nice.
http://www.masm32.com/

Good luck!
thanks. Ive decided to learn masm now. Also Im doing some stuff with nasm. Ive also figured out how to run the program.
Topic archived. No new replies allowed.