SFML help

closed account (Dy7SLyTq)
i wanted to use networking and i knew sfml let me do that so i downloaded sfml cd'ed (it was on my desktop) to it in terminal and typed in sudo make install like the website said to. i made a program to test it out and it compiled fine, but when i tried to run it i got ./clock: error while loading shared libraries: libsfml-system.so.1.6: cannot open shared object file: no such file or directory

i compiled with g++ clock.cpp -o clock -lsfml-system
Add -static in the command line.
closed account (Dy7SLyTq)
tried that; got /usr/bin/ld: cannot find -lsfml-system
collect2: error: ld returned 1 exit status
Then your lib is not installed properly, there must be some specific files in /usr/include /usr/lib or same subdirectories in /usr/local
Try pointing the compiler with -I path to your libs dir and -L path to include dir of your lib something like -I /home/sfml/include -L /home/sfml/lib but it might not work because compiler default path where he's looking for files is that with /usr/
Last edited on
Topic archived. No new replies allowed.