zlib1.dll is missing

Hello I recently started to learn c++ but I bumped in to a problem that I could not solve myself. (I am using Visual Studio 11). I was trying to use curl from: http://curl.haxx.se

I am able to compile one of the example codes but when I try to start application it it gives me error message:
"This program can't start because zlib1.dll is missing from your computer...".

I tried to download zlib1.dll from various different sources but when I put it into my project directory it gives me another error:
"The ordinal 72 could not be located in the dynamic link library..."

I read that this is probably because curl using different version of zlib1.dll than I have, but I was unable to find the right one. I tried so many things and still could not run the application.

I tried downloading the source of zlib from zlib.net but by trying to compile it I get 15 errors.

Can someone give any suggestions?
I downloaded the version which included zlib1.dll file:


Topic archived. No new replies allowed.