Problem with Dev-C++!

I'm making a Win32 application, and compiling worked fine... until now. Dev-C++ throws a syntax error in my face. It shows the error in an empty line of the private resource. I tried to delete the resource, but upon regenerating, I still get the error. How can I remove it?
Try creating the resource with ResEdit:

Or post which line gives an error.
Last edited on
Here is it:
2 /* DO NOT EDIT! */
4 #include "mymenu.rc"
5 (line which produces the error)

You're at least using wxDev-C++ right: ? Usually I just assume people are writing the name short hand but I just want to make sure.

Shouldn't Line 4 be a .hpp file and not the name of the resource file itself?

Could you copy and paste the entire error from dev-C++? What happens after you start adding resources to the file?

No, the program doesn't generate .hpp files. Maybe I should reassemble the project or use Orwell Dev-C++.
Last edited on
You can't use a resource file without a header file, this is a fact. Just like when you link to another .c\.cpp file, the header file is what defines declares the data in a resource file to the rest of the program.

Again, please copy and paste the entire error given to you by Dev-C++, if you add up all of the contributors on this site I guarantee that collectively we have made every possible mistake and have seen every error code so chances are someone here has seen the error your are getting before.
Last edited on
Topic archived. No new replies allowed.