Tried for hours to make threads work.

Hi. I am about to rip my non-existing hair out and punch a hole in my monitor.

I wanted to start learning how to use threads. But I haven't even been able to start coding yet. I am still stuck with installing and setting configuarions and such.

First I tried to install Boost on Visual Studio 2010 which did not work.
Then I installed CodeBlocks and tried to make C++11 work with support for threads.
I set the compiler options to use g++ with c++11 and c++0x standards and that did not work either.

Can anybody please help me? Are there no simple options of just downloading a freaking IDE with C++11 setup from the beginning? What should I do? :(

Boost should work fine with VS2010 or VS2012. The 2013 preview apparently has some issues (with boost,) but both VS2012 and the 2013 preview have some C++11 support, including support for std::thread.
Last edited on
I know that but VS2012 always stops working after about 2 days for some reason. I am currently downloading and installing VS2013. If this does not work I do not know what to do.

Thanks for all help and sorry for my rage.
Topic archived. No new replies allowed.