How add the pkg-config option to bjam in boost libraries

Dear friends,

I am compiling my one module program by using the following command gcc -g -o `pkg-config --cflags glib-2.0 dbus-libs-1 --libs glib-2.0 dbus-libs-1` -lm -lpthread main.c main

but I don't know how to add this option to bjam because the module code which I compiled using make above is to integrated into my big project so there I used bjam because of I'm using boost c++ libraries .

please tell how to set this option in bjam.

Best Regards
You need bjam only for compiling the boost libraries. Once boost is compiled you can forget it. You don't need it for your project
please see if it is not required means it should not through error right but it is showing error has dbus/dbus.h file not found fatal error but when I compiled with gcc pkf-config options it is not showing.
Do you mean this:

it seems that pkg-config has something to do with versions. I never used it instead I solved that with links which seems to be easier.

Are there any connections between boost and dbus anyway? I rather think that there're some files or path settings missing. I'd suggest use a decent IDE instead of compiling it directly
yes , that pkg-conf only .
Topic archived. No new replies allowed.