Help!!!

How my program to loo like this

Sample Input
1
2
3
4
3
3 5 4
1 2 1
3 3 1 


Sample Output
1
2
3
3 5 4 : RIGHT TRIANGLE WITH AREA 6.00000 UNITS SQUARED 
1 2 1 : NOT A TRIANGLE
3 3 1 : TRIANGLE WITH AREA 1.47902 UNITS SQUARED



and..this is my code..
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
int main()
{
    double x,y,z;
    int N;
    float Area,s;
    
	cin >> N;
		if (N > 1000)
			return 0;
			
for (int i = 1; i <= N;i++)
   
   {
    cin >> x;
		if ( x > 5000)
			return 0;
	cin >> y;
		if ( y > 5000)
			return 0;
	cin >> z;
		if ( z > 5000)
			return 0;
	

    	s = ( x + y + z ) / 2;
    	Area = sqrt ( s * ( s - x ) * ( s - y ) * ( s - z ));
 
		int B = Area;
 
 
  
    	if ( (B % 3) == 0 && ( x != y != z))
		  {
    			cout << x << " " << y << " " << z ; 
    			printf (" : RIGHT TRIANGLE WITH AREA %1.5f UNITS SQUARED\n",Area);
		  }
	
		
		if ( Area == 0)
		  {
			cout << x << " " << y << " " << z ; 
			cout << " : NOT A TRIANGLE" << endl;
		  }
	
		
		else if ( (B % 3) > 0)
			{
    			cout << x << " " << y << " " << z ; 
    			printf (" : TRIANGLE WITH AREA %1.5f UNITS SQUARED\n",Area);

			}
   }

    return 0;
}


NOTE: using array is not allowed!
this is a duplicate of your other thread. DON'T DO THIS
this is a duplicate of your other thread. DON'T DO THIS


but..my other thread is not yet solved..i have a certain changes in my code..so..i posted a new thread..
Ok, Just keep one thread going, otherwise you will have new threads all over the place. The problem is that someone might write lots of stuff into one thread, only to discover someone else has written heaps into the other one. As well as this, you threads are on different boards.

Apart from that you haven't said what the particular problem is now.

I don't think it will compile, so post your compiler output.

You have confused ideas about your data types.
Topic archived. No new replies allowed.