Building wxWidgets with MinGW

Pages: 1234
I'm having a whole lot of problems trying to build wxWidgets. I followed the directions step by step.

instructions from

For some reason mingw32-make -f makefile.gcc BUILD=release SHARED=1 MONOLITHIC=1 UNICODE=1 doesnt work in command prompt... Can someone please hlpe me out?? It says that mingw32-make isn't a command.
Last edited on
Is the mingw/bin directory in your PATH? Also, if you have MSYS installed try make

Edit: It is compiling for me following the directions on your link, but I am using the mingw shell that comes with my installation.
Last edited on
MinGW shell?? I have no clue how I'm supposed to install this...

I dont have MSYS, whatever that is. "make" isn't a recognized command prompt command, so I can't use it.

MinGW: C:\MinGW
wxWidgets (un-'built'): C:\Program Files\Codeblocks\wxWidgets
Last edited on

As for mingw shell, it came with my mingw installation I believe. Actually, I think it comes with MSYS. I access it under the mingw entry in Programs menu.
Last edited on
The link you provided me will make me re-install MinGW. Currently, i have MinGW working perfectly with the boost library, and I would like it to stay that way.

Thank you for your help. If you cvould provide me with the link to installation of MSYS independently, I would appreciate it. I will do some searching though.
No, you dont need to reinstall mingw, this link is on the page I linked previously
Alright. Thank you so much for yuour help!

I will post any other problems I have with this here. I just hope there aren't any. :)
So i tried following the instructions using MSYS, and it still didnt work... MSYS doesn't have a 'make' command either.

Am I missing something??
Last edited on
I have make.exe in mingw/bin and mingw/msys/1.0/bin. Are you using mingw shell?
Im using MSYS.....

I'm not exactly sure how to use a shell.
Last edited on
Go to start>programs>mingw>mingw shell or run msys/1.0/msys.bat
thats what I have been using and it keeps telling me that "mingw32-make isnt a command".
Did you check for make.exe?

It (i think...) recognizes it, but doesn't do a thing.

When I try to build a wxWidgets Project (blank, nothing but the 'close()' command) it keeps showing this error:

C:\Program Files\CodeBlocks\wxWidgets-2.8.12\include\wx\platform.h|196|fatal error: wx/setup.h: No such file or directory|

The command I'm entering into the consol:
mingw32-make -f makefile.gcc BUILD=release SHARED=1 MONOLITHIC=1 UNICODE=1
Last edited on
See the FAQ at the bottom of the page you linked in your first post.
Wow i feel dumb ...

Well, adding "$(#wx.lib)\gcc_dll\mswu" to the compiler search direstories didnt help. (under the first tab)

I've tried as many different program "configuratoons as i can think of, and I still get that same damn error.

EDIT1 - I've tried adding "$(#wx.lib)\gcc_dll\mswu" under a lot of build options and none of it seems to help. The project is set for monolithic, dll, and unicode. I dont know what that is supposed to mean, but apparently it has to be set up that way for "$(#wx.lib)\gcc_dll\mswu" to work, which it doesn't anyway. wxWidgets, Y U NO WORK?!?!

Any help is greatly appreciated. I have done some searches and most of what I get is about VISUAL, not MinGW, but none about my problem specifically.
Last edited on
After a bit more un-conclusive searching, I am wondering what the problem is...

I've read some stuff about 'compiling the wxWidgets library wrong', if that's even possible..., and other stuff that refers to the same link in my first post. I can not figure out how to get widgets to work!!

If someone could provide step by step instructions so that they can 'diagnose' what's wrong with it, i would be very grateful. I'm about to abandon my attempts to make GUIs all together if I can't get this to simply work.

I would also like to note that attempts at building the wxWidgets using the instructions provided in the link of my first post, didn't seem to do anything. I put in the command and almost as fast as I pressed enter it showed me the input ">", and nothing more. No buils statistics/directories, etc, nothing. It was as if it didn't even try to build the library, so I'm going to take that as a confirmation that the wxWidgets library is properly built, until someone tells me otherwise.

I'm learning this on my own, this is not part of a school project, or otherwise. Any help you give is greatly appreciated.
Last edited on
When building you will see the compiler output, it also takes some time (I think about 45 mins for me). I'm thinking either you aren't entering the command correctly, your PATH doesn't have necessary directories or there is an issue with your mingw installation. Where you able to find the mingw shell I mentioned? If so try this command that worked for me
make -f makefile.gcc BUILD=release SHARED=1 MONOLITHIC=1 UNICODE=1
You can also try a more recent version of wxwidgets, the version I compiled was 2.9.4, but I doubt that is the issue.

Edit: Don't give up, while it can be a pain in the ass to build/link/use external libs it is necessary skill you will need to learn to be productive as a programmer.
Last edited on
Alright, i will keep trying.

make -f makefile.gcc BUILD=release SHARED=1 MONOLITHIC=1 UNICODE=1

That was the exact code i used, except i used
instead of
. It didnt give me "not a command" or nothing. It just simply acted as though i didnt enter anything at all... I will try make instead though.

Also, I followed the instructions and changed the directory (C:\Program Files\CodeBlocks\wxWidgets-2.8.12\build\msw) if that changes anything.

Well, the entire FREAKING folder that contains All my prograsmming tools, wtc... is READ-ONLY! that must be half of my problem right there. Why in hell would my computer do this?? It wont let me change this from read only!!!!
Last edited on
Pages: 1234