MinGW Doesn't want to work anymore :|

Pages: 12
Explaining the problem is quite simple and weird:

 | cc1plus.exe - Application error                                             | 
 |  ___                                                                        | 
 | /\ /\  The application was unable to start correctly (0xc0000013). Click OK | 
 | | X |  to close the application.                                            | 
 | \/_\/                                                                       | 
 |                                                                     |       | 

Tried redownloading the same distro, tried switching to another distro, TRIED REMOVING MY ANDROID MOBILE FROM THE USB PORT.
Why do I mention that?
Because it seems like 0xC0000013 error happens when a device isn't actually "plugged in" or just "inserted" (Much like a SD reader without a SD card inside).

Got any clues?

I've put too much time on that.

EDIT: Can someone tell me his cc1plus.exe's file size? Mine's in mingw\libexec\gcc\i686-w64-mingw32\4.8.1
Last edited on
Have you tried turning it off and on again?
Same thing.
Try running Process Monitor alongside it (I recommend filtering unrelated processes) and see if you can spot the error to get any more information.
Okay, this is weird, but at least I solved it.
cc1plus.exe wants libwinpthread-1.dll in its directory, not just in the global PATH.
(Obviously noticed via ProcMon).

This is so weird, the built program is doing the same thing.
I've got a bad feeling.

Okay, I think I should put all the DLL's in /mingw/opt/bin.

Okay, got it working.
It's enough for the moment, thanks anyways.
Last edited on
Okay, back to unknown things.
On big projects, it ALWAYS fully re-compiles from scratch.
I also noticed things like this:


MinGW-4.7.1? I've never used that folder not even while installing.
I can't even find SH.exe itself.
(where sh gives no results)


The hell? Besides being system files, they're not even there.

Something wrong with Windows?
Note that a LoadLibrary() call generates a cascade of file system queries to find the library. The system doesn't know ahead of time that a given DLL is not in any of the directories it's not in.
Fact it is, it never shows a call to FileOpen to C:\Windows\System32\*.dll with the DLLs shown above (as they actually lie in System32 folder).
Also, by the environment path order, C:\Windows\System32 should be checked BEFORE C:\mingw\bin .
I believe System32 is always searched last to allow overriding without messing around with system files.
Oh well I'm not sure, but I'm certain there wasn't a cascading of queries for those DLL's.
That was the EXACT SAME sequence taken from Process Monitor.
You know what I would be thinking: RED FLAG: virus alert...

I would be running an AV/A-spyware scan asap and see what I find... unless, it wasn't just a "suddenly-for-no-reson-stopped-working" scenario...

I would probably just re-install the entire setup altogether (no matter the trouble). I wouldn't try to gut out the system to fix the solution.

Whatever you do, best of luck to you.
Last edited on
I don't think that's a virus.
Any other program seems to be working fine.
Steam, TeamSpeak, even high-quality games like CS:GO don't seem to have any extra FPS drop (I'd be noticing, I regularly have 40fps and still have them).
HDD space is under control.
No new processes in the Task Mgr.
RAM is at a reasonable level too.
GPU not heating up while idle.
Other than that, I haven't run any suspicious EXE recently.

About reinstalling, I've done it already as mentioned in the first post.
I'm certain I've done it at least 4 times, probably even 6 or 7.
(Distro = MinGW Distro)
Last edited on
yikes... well, obviously somthing is out of wack here.... you're looking in the wrong place. Check your OS' settings to see if the OS is screwing your install.

Also, what OS? W8 or 7?
7 x86.
Well I begun without clearly knowing what was happening.
The alternative is a clean OS install. Run the AV just in case.
I wanted to avoid that...
I think I'll keep a list of installed programs and everything else on my 2nd partition, and go for it then.
Well, That's what I would do. Curious as to why you want to avoid that?
closed account (zb0S216C)
I had the same problem, but in my case, the problem was down to a stack-overflow within "cc1plus.exe". I never managed to rectify the problem so I had to replace the entire suite with a earlier version. I think the SO was reported as a bug. I addition, another bug had arose with the internal exception-handling call-backs as well.

Last edited on
Windows, do you hear this? I hope you're reading this Billy, because I really really really hate that you want me to switch to 8.1 and that you made my machine, with your infernal operating system, display this STUPID "notice" to upgrade to 8.1.

I'm waiting a few months until Qt can make it work with 8.1, then I'll switch. Last thing I need it windows screwing my compiler over...
Last edited on
@IWishIKnew: So I could keep all my programs/settings/etc intact.
Right now I'm using Universal Usb Installer to get Windows 7 on my USB drive, while I'm making the list of programs to restore afterwards.
Pages: 12