Visual Studio 2013 Express: IntelliSense is not working

The last time when I closed VS13, a message showed up and said there's something wrong with SQL so IntelliSense's not working. After that, I tried to uninstall everything. And then I installed VS13 again but IntelliSense is still not working. So I've tried to reset the settings by Tools > Import and Export Settings > Reset all settings. But ya know it's still not working.

EDIT:
Detail about SQL problem:
"An error occurred while creating or opening the C++ browsing database file [project directory]\[project name].sdf. IntelliSense and browsing information will not be available for C++ projects.

Ensure that Microsoft SQL Server Compact 4.0 is installed and that no other applications are accessing the file. If this problem persists, delete the file and reopen the solution"

But there is no .sdf file and I'm still getting this after installing VS13E again.
Last edited on
Go to TOOLS / Options / Text Editor / C++ / Advanced / Always use fallback location = True.
Restart Visual Studio and see if it works (create a new project).

No, thanks. I've uninstalled Microsoft SQL Server Compact 4.0 and reinstalled it. Open up VS13 and it's working. Thanks for replying anyway.
That usually happens when a file is already open from something else. I see it most often when I open the same solution twice. Re-installing everything seems like an extreme solution. I'd rather first see what else is running, and if you don't find anything related, I'd simply reboot.
Registered users can post here. Sign in or register to post.