Is any mathematical term for integer number for which factorial is evaluated?i

Pages: 12
But in my opinion a variable or an argument are too general notions. I thought that there is a more specific term for argument of factorial.

Could it be for example a degree or is it a wrong term?


So, is it the exponential of degree x or argument x? For your case, why not antecedent [of the factorial]?

Last edited on
In my opinion, the (n) in n! is just the factorial degree, the number of times the factorial is called. Could this not suffice? Is degree not a proper term for it?
@Volatile Pulse
In my opinion, the (n) in n! is just the factorial degree, the number of times the factorial is called. Could this not suffice? Is degree not a proper term for it?


I have the same opinion, but I did not find the words "factorial degree" in internet.
+1 ne555

inverse_factorial() for the inverse of the factorial() function.

Any other name should come into consideration if and only if the domain of the inverse function is different from the range of the original function.
Last edited on
I have heard the term factorial mentioned to describe n before as well. n! is n factorial, but n is the factorial. It doesn't seem right that the number has the same name as the formula, but is it not possible too?

Edit: After doing some researching, it seems that a large majority of sites and books simply refer to n as just n as if it has no technical name but just n. If none of the terms here have worked for you, I would just stick with using n as the term.
Last edited on

@JLBorges
inverse_factorial() for the inverse of the factorial() function.

Any other name should come into consideration if and only if the domain of the inverse function is different from the range of the original function.


The domain of factorial( n ) is indeed different from the domain of n. n is size-T while factorial( n ) is any integer type, for example, long long.
Besides to denote maximum acceptable value of n as max_inverse_factorial is not a very good idea. The name reverse_factorial is more suitable for some algorithm.
The domain of factorial( n ) is indeed different from the domain of n. n is size-T while factorial( n ) is any integer type, for example, long long.


The domain of n! is all positive integers. The range of n! would be the set of all of values of n! given the domain.

The domain of your inverse n! function should be the range of n!. That is, your input should always be a number which is the value of n! for some integer n.

What he was saying here:


inverse_factorial() for the inverse of the factorial() function.

Any other name should come into consideration if and only if the domain of the inverse function is different from the range of the original function.


Is that you should only consider a name other than inverse factorial, if your function produces output for non-factorial input. For example, if the set of acceptable inputs included the number 9, which has no inverse factorial, because for all n, n! != 9.

If a user tries to calculate the inverse factorial of 9, your program should give you an message, like D.N.E. , for does not exist, or something.


Last edited on
inverse_factorial - is a very bad idea. As I said it looks like inverse_copy that is as an algorithm name.

Moreover as I mentioned the domain of n and the domain of factoria(n )l are different The domain of n is 0 - UINT_MAX while the domain of the factorial( n ) can be, for example 0 - LLONG_MAX or 0 - CHAR_MAX. Moreiver I do not evaluate n because n is given. I only need a name for a GETTER.
Repeat:
Any other name should come into consideration if and only if the domain of the inverse function is different from the range of the original function.

This simplified definition may enlighten those who haven't studied elementary algebra:

In crude terms, the domain is the set of all possible values that can go into a function;
and the range is the set of all possible values that can come out.
I'd simply suggest GetN or GetFactorial, or GetDegree.

Even if none of those terms are technically correct, you understand what they do, and the user should understand what is meant by them. I would suggest using the Degree or N since Factorial is too easily confused with the name.

If it's for personal use, it really doesn't matter. If it's for release version, it still really doesn't matter. And if it's for commercial use/release, ask the audience of it. I don't believe there exists a technical term for n and as such, there is no real right or wrong.

P.S. Couldn't you use GetFactorialN?
GetFactorialN is too long. As i said early I need also something as GetMaxFactorialN. So I would prefer do not use name Get.
Now I have three pretendents

degree max_degree
base max_base
argn max_argn


What is the better?:)
I wanted to name a function that returns n for a given value of factorial( n ).
I do not evaluate n because n is given. I only need a name for a GETTER.
I'm confused
I thought that you wanted something like int n = inverse_factorial(120); ¿how do you intend to use it?

I prefer factorial::{,max_}argn
Last edited on
I am going to use it as for example

factorial<long long> f( 10 );

std::cout << f.base() /* or f.argn() or f.degree() */ << std::endl;

P.S. @ne555 could you say to the people of your country that the mark ¿ is superfluous in an interrogative sentence? :)
Last edited on
Topic archived. No new replies allowed.
Pages: 12